Beta Release discussion (#1) - Game Server Web Application (#12) - Message List

Game Server Web Application

I got the GameServer up and running for the Network Defense scenario. Anyone has any idea on how to start and use the Game Server Web Application?

Thanks! Jans

  • Message #57

    He jans,

    Did you managed to get the Web app, im looking for days without any success.

    • Message #58

      Hi malcrove,

      Yup, got it working finally! The Web App is only working on the latest version of GameServer. Once the GS is running, just point your browser to the GS's server IP address port 3000.

      Hope this helps

      • Message #59

        Cool, only when I do netstat -antup I don’t see any port 3000 running, I tried versions 1.0 and 1.2

        Maybe if you have any time we can setup and hangout call and share my screen and show you.

        My email is mea@….

        Thanks for the support

      • Message #60

        Hi gents,

        Yeah for me either, while i was trying to get the netdef scenario work, i was able to import all VMs using occpadmin including gameserver on our esxi; after running occpgs binary with appropriate params, the gameserver runs the API under port 4567 which i can fetch successfully using curl, but after looking for the webapp binding on port 3000, nothing found.

        I'm using occpadmin 1.0 because they mention on the forum that netdef doesn't work with new occpadmin (1.2).

        Can you please share the steps behind making the gameserver 100% work !? i mean exposing the GS webapp that fetches the gs API.



        • Message #61

          Somehow, there are some very strange behaviors in the puppet scripts for both version 1.0 and 1.2.

          For v1.0, what I did to make the netdef scenario work was to modify the XML to let the AdminVM-1.0 setup VMs one-by-one. Just remove the <host> portions and run AdminVM-1.0 multiple times, each for a different host.

          So, for the GameServer, I just kept the <host> section for the 'gameserver' and deleted the rests. Still couldn't get the mailserver and the dns working, so I setup these 2 VMs manually.

          The GameServer v1.0 is different than v1.2, though. Version 1.0 doesn't have the Web App. So, I used the 'referenceVSN' version 1.2 to build the new GameServer using the same method, kept the GS <host> section and deleted the rest.

          However, I noticed some strange behaviors. Somehow the AdminVM-1.2 jumped from 'phase1' immediately to 'phase2' during the build. Not sure why but this skipped the installation of the GameServer functionalities, including the WebApp?.

          So, what I did was simply modify the 'init.pp' manifest puppet script in the ContentPack? for 'gameserver' to run everything from the start, removing all the 'phase1' and 'phase2' conditions. This violates the design from the original author, but at this point I haven't got any chance to look into why the AdminVM behaves like this.

          The result is just a working GameServer with the WebApp? working as expected :-)

          Hope this helps.

          • Message #62

            Hi, Thanks for your prompt answer, Yes definitely, i used the same way to be able to import all those VMs, otherwise, you will fall into an endless loop says:

            WARNING edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "gameserver" on the hypervisor "malesxi" has now failed 210 times. Retrying...

            In my case, i removed only the <host> tag pertains to rhinowww from netdef and it worked.

            For the gameserver web app, i just download the referenceVSN and i found the occpgswebapp.

            Please what do you mean by new version of gameserver, there is only one OVA file ? do you mean the old GS VM with modification along with the found gs webapp is concidered as new gameserver ?

            • Message #63

              What I meant was I was using the newer 16.04 Base VM for the gameserver :-) I think version 1.2 is using puppet 4, so I figured the newer BaseVM should be installed with puppet v4.

              Also, internally, the GameServer itself has a separate versioning by itself, the latest being gameserver-0.2.3, this is the one that has the webapp.


No attachments created.

You must login to post a reply.