[OCCP] Topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/topic/12 <p> Game Server Web Application </p> en-us OCCP https://opencyberchallenge.net/chrome/site/logo.png https://opencyberchallenge.net/discussion/topic/12 Trac 1.0.13 - DiscussionPlugin occpuser Thu, 19 Apr 2018 03:09:00 GMT Topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/topic/12#topic https://opencyberchallenge.net/discussion/topic/12#topic <p> I got the <a class="wiki" href="/wiki/GameServer">GameServer</a> up and running for the Network Defense scenario. Anyone has any idea on how to start and use the Game Server Web Application? </p> <p> Thanks! Jans </p> Topic occpuser Fri, 20 Jul 2018 07:26:05 GMT Reply #63 to topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/message/63#message63 https://opencyberchallenge.net/discussion/message/63#message63 <p> What I meant was I was using the newer 16.04 Base VM for the gameserver :-) I think version 1.2 is using puppet 4, so I figured the newer BaseVM should be installed with puppet v4. </p> <p> Also, internally, the <a class="wiki" href="/wiki/GameServer">GameServer</a> itself has a separate versioning by itself, the latest being gameserver-0.2.3, this is the one that has the webapp. </p> Message shellcoder Fri, 20 Jul 2018 06:22:12 GMT Reply #62 to topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/message/62#message62 https://opencyberchallenge.net/discussion/message/62#message62 <p> Hi, Thanks for your prompt answer, Yes definitely, i used the same way to be able to import all those VMs, otherwise, you will fall into an endless loop says: </p> <pre class="wiki">WARNING edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "gameserver" on the hypervisor "malesxi" has now failed 210 times. Retrying... </pre><p> In my case, i removed only the &lt;host&gt; tag pertains to rhinowww from netdef and it worked. </p> <p> For the gameserver web app, i just download the referenceVSN and i found the occpgswebapp. </p> <p> Please what do you mean by new version of gameserver, there is only one OVA file ? do you mean the old GS VM with modification along with the found gs webapp is concidered as new gameserver ? </p> Message occpuser Fri, 20 Jul 2018 02:08:59 GMT Reply #61 to topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/message/61#message61 https://opencyberchallenge.net/discussion/message/61#message61 <p> Somehow, there are some very strange behaviors in the puppet scripts for both version 1.0 and 1.2. </p> <p> For v1.0, what I did to make the netdef scenario work was to modify the XML to let the AdminVM-1.0 setup rhinoribbons.org VMs one-by-one. Just remove the &lt;host&gt; portions and run AdminVM-1.0 multiple times, each for a different host. </p> <p> So, for the <a class="wiki" href="/wiki/GameServer">GameServer</a>, I just kept the &lt;host&gt; section for the 'gameserver' and deleted the rests. Still couldn't get the mailserver and the dns working, so I setup these 2 VMs manually. </p> <p> The <a class="wiki" href="/wiki/GameServer">GameServer</a> v1.0 is different than v1.2, though. Version 1.0 doesn't have the Web App. So, I used the 'referenceVSN' version 1.2 to build the new <a class="wiki" href="/wiki/GameServer">GameServer</a> using the same method, kept the GS &lt;host&gt; section and deleted the rest. </p> <p> However, I noticed some strange behaviors. Somehow the AdminVM-1.2 jumped from 'phase1' immediately to 'phase2' during the build. Not sure why but this skipped the installation of the <a class="wiki" href="/wiki/GameServer">GameServer</a> functionalities, including the <a class="missing wiki">WebApp?</a>. </p> <p> So, what I did was simply modify the 'init.pp' manifest puppet script in the <a class="missing wiki">ContentPack?</a> for 'gameserver' to run everything from the start, removing all the 'phase1' and 'phase2' conditions. This violates the design from the original author, but at this point I haven't got any chance to look into why the AdminVM behaves like this. </p> <p> The result is just a working <a class="wiki" href="/wiki/GameServer">GameServer</a> with the <a class="missing wiki">WebApp?</a> working as expected :-) </p> <p> Hope this helps. </p> Message shellcoder Thu, 19 Jul 2018 06:50:39 GMT Reply #60 to topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/message/60#message60 https://opencyberchallenge.net/discussion/message/60#message60 <p> Hi gents, </p> <p> Yeah for me either, while i was trying to get the netdef scenario work, i was able to import all VMs using occpadmin including gameserver on our esxi; after running occpgs binary with appropriate params, the gameserver runs the API under port 4567 which i can fetch successfully using curl, but after looking for the webapp binding on port 3000, nothing found. </p> <p> I'm using occpadmin 1.0 because they mention on the forum that netdef doesn't work with new occpadmin (1.2). </p> <p> Can you please share the steps behind making the gameserver 100% work !? i mean exposing the GS webapp that fetches the gs API. </p> <p> thanks. </p> <p> shellcoder </p> Message malcrove Thu, 19 Jul 2018 06:09:55 GMT Reply #59 to topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/message/59#message59 https://opencyberchallenge.net/discussion/message/59#message59 <p> Cool, only when I do netstat -antup I don’t see any port 3000 running, I tried versions 1.0 and 1.2 </p> <p> Maybe if you have any time we can setup and hangout call and share my screen and show you. </p> <p> My email is mea@…. </p> <p> Thanks for the support </p> Message occpuser Thu, 19 Jul 2018 03:02:29 GMT Reply #58 to topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/message/58#message58 https://opencyberchallenge.net/discussion/message/58#message58 <p> Hi malcrove, </p> <p> Yup, got it working finally! The Web App is only working on the latest version of <a class="wiki" href="/wiki/GameServer">GameServer</a>. Once the GS is running, just point your browser to the GS's server IP address port 3000. </p> <p> Hope this helps </p> Message malcrove Tue, 17 Jul 2018 11:05:06 GMT Reply #57 to topic #12 - Game Server Web Application https://opencyberchallenge.net/discussion/message/57#message57 https://opencyberchallenge.net/discussion/message/57#message57 <p> He jans, </p> <p> Did you managed to get the Web app, im looking for days without any success. </p> Message