Beta Release discussion (#1) - Cannot setup network for netdef.xml (#10) - Message List

Cannot setup network for netdef.xml
 unsolved

After running the --mode launch --config netdef.xml I get error: /etc/openvpn/up.sh can not be found

I see connections to my virtwebsrv but it errors out when searching or using up.sh file.

  • Message #50

    Hello,

    Have you just installed the OCCP recently? Please be aware that we are in the process of publishing the latest 1.2 version. The Network Defense scenario has not been recompiled for the 1.2 version and will require the version 1.0 VMs.

    • Message #51

      Downloaded the v1.0 and went thru same steps. Still running into up.sh error.

      occpadmin@adminvm:/media/sf_OccpShared$ occpadmin --mode addhv --hvname myOCCPHV --hvtype vbox --url http://172.34.39.71:18083 --username --password --importdir /media/sf_OccpShared/rhinoribbons INFO edu.uri.dfcsc.occp.OccpAdmin main: Added hypervisor: myOCCPHV occpadmin@adminvm:/media/sf_OccpShared$ occpadmin --mode deploy --hvname myOCCPHV --config /media/sf_OccpShared/rhinoribbons/netdef.xml INFO edu.uri.dfcsc.occp.OccpParser? parseConfig: Reading the scenario configuration file INFO edu.uri.dfcsc.occp.OccpParser? parseConfig: Finished reading the scenario configuration file INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Report directory: /media/sf_OccpShared/rhinoribbons/Reports INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Moderator.txt INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Instructions.txt INFO edu.uri.dfcsc.occp.OccpAdmin main: Connected to myOCCPHV INFO edu.uri.dfcsc.occp.OccpAdmin main: Checking appropriate networks exist on hypervisors WARNING edu.uri.dfcsc.occp.SetupNetwork? setup: Failure starting openvpn:Options error: --up script fails with '/etc/openvpn/up.sh': No such file or directory Options error: Please correct this error. Use --help for more information.

      SEVERE edu.uri.dfcsc.occp.OccpAdmin main: Failed to setup setup network

      • Message #52

        so the bridge network must be assigned to eth0 which may not show on Virtual Box settings so it required me to have to switch them. Once I did that, all VMs loaded and configured. I went to log into Gamerserver with default account root/0ccpadmin and when I hit the up arrow for "sudo occpgs -f instance.xml" it doesn't appear so we typed it manually and error out withy "file doesn't exist".

        Had to type "sudo occpgs -f /usr/local/gameserver/instance_file.xml which loaded list of options:

        1. Start
        2. Pause
        3. Status
        4. Clear Screen
        5. Quit

        We selected 1. Start and errored out with unable to start network namespace for event failed to set link eth1 to promisc mode

        We had to go manually apply eth1 and was able to start the Gameserver to get another error of Gametime : Expired which was 15secs and Red Team won in 15secs.

        I think I give up Folks** Too many errors and too much troubleshooting which defeats learning experience with scenarios. I Tried*

        • Message #53

          I'm sorry you had so much difficulty getting everything setup.

Attachments

No attachments created.

You must login to post a reply.