Beta Release discussion (#1) - Installing NetDefense? Scenario Ready to use (#3) - Message List

Installing NetDefense? Scenario Ready to use
 unsolved

Hello, I´m newbie here so I hope don´t make mistakes! I´m trying to install the Ready-to-use scenarios for teachers and challenge coordinators.

I´m following these steps: https://opencyberchallenge.net/wiki/ScenarioNetDefense

But on the fifth step...I can´t make it work.

I wrote this command first:

vboxwebsrv -b -H 192.168.1.56 -A null

And I get this output:


Oracle VM VirtualBox web service Version 4.3.10_Ubuntu

(C) 2007-2015 Oracle Corporation
All rights reserved.
VirtualBox web service 4.3.10_Ubuntu r93012 linux.x86 (May 22 2015 02:58:51) release log
00:00:00.000305 main Log opened 2015-11-02T17:42:16.850923000Z[[BR]] 00:00:00.000306 main Build Type: release
00:00:00.000307 main OS Product: Linux
00:00:00.000308 main OS Release: 3.13.0-39-generic
00:00:00.000308 main OS Version: #66-Ubuntu SMP Tue Oct 28 13:31:23 UTC 2014
00:00:00.000323 main DMI Product Name: VirtualBox
00:00:00.000327 main DMI Product Version: 1.2
00:00:00.000379 main Host RAM: 495MB total, 412MB available
00:00:00.000381 main Executable: /usr/lib/virtualbox/vboxwebsrv
00:00:00.000381 main Process ID: 2061
00:00:00.000382 main Package type: LINUX_32BITS_GENERIC (OSE)


I´m not sure but it seems all is working correctly but then I write:

occpadmin --hvtype vbox --importdir /mnt/OccpShared --url http://192.168.1.56:18083/ --username 'occpadmin' --password '0ccpadmin' --mode launch --config netdef.xml

And here is the error.....


INFO edu.uri.dfcsc.occp.OccpParser? parseConfig: Reading the scenario configuration file
INFO edu.uri.dfcsc.occp.OccpParser? parseConfig: Finished reading the scenario configuration file
INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Report directory: /mnt/OccpShared/rhinoribbons/Reports
INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Moderator.txt
INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Instructions.txt
SEVERE edu.uri.dfcsc.occp.OccpVBoxHV connect: Connection failure connecting to http://192.168.1.56:18083/[[BR]] org.virtualbox_4_3.VBoxException: HTTP transport error: java.net.ConnectException?: Connection refused

at org.virtualbox_4_3.VirtualBoxManager?.connect(VirtualBoxManager?.java:185)[[BR]] at edu.uri.dfcsc.occp.OccpVBoxHV.connect(OccpVBoxHV.java:148)[[BR]] at edu.uri.dfcsc.occp.OccpAdmin.main(OccpAdmin.java:2297)[[BR]]

Caused by: com.sun.xml.internal.ws.client.ClientTransportException?: HTTP transport error: java.net.ConnectException?: Connection refused


Please any help or recommendation? Thanks, regards.

Tree View Flat View (newer first) Flat View (older first)
  • Message #64

    Hi LT_smash,

    Could you share the steps and configurations?

  • Message #56

    Hi chanel.d.bernal,

    Any chance that you got the scenario working? I've been trying but still not working despite all the suggestions here in this thread.

  • Message #49

    Does anyone know why it gives me an error /etc/openvpn/up.sh can not be found ?

    Fix: Had to create an up.sh file

  • Message #38

    Fine! I got it, now it hacks part of the website. Now I want to learn how to avoid this attack, and once the attack have hacked the website how to fix it... thanks!

  • Message #37

    You should specify --mode deploy --regen.

    Specifying poweroff makes that the only action, although now that you have done it, it might not pick up the that netdef.xml has changed, so you'll have to specify --regen to get it to restart.

    --regen rolls the machines back to phase 1 (as they were when they were imported), and then runs the phase 2 configuration.

  • Message #36

    Hi bryank, there is a bug with VirtualBox 4.3 on Windows 10, but that bug only affects to VBox doesn´t recognise my network card, so you have to configure the first network AdminVM NAT type, and (if you want) you can control it by SSH with port forwarding.

    When I change the netdef.xml, what do I have to do to load the changes and work with my last version? I think I have to delete and relaunch the scenario.. I tried to power off the scenario and power on, I get this kind of message when I change the netdef.xml:

    INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Scenario file is newer than instance, regen mode was not requested but is now being forced
    INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Reading the scenario configuration file
    INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Finished reading the scenario configuration file
    INFO edu.uri.dfcsc.occp.OccpAdmin main: Connected to specified
    INFO edu.uri.dfcsc.occp.OccpAdmin main: poweroff completed with regen
    

    Thank you.

  • Message #35

    I'm curious how you got it to work on Windows 10 since I thought we decided there was a bug with VirtualBox 4.3 on that version.

    In any case, there is a slight issue in the XML file that ships with that scenario where you need to modify the "egallery deface" event to include:

    > /dev/null 2> /dev/null
    

    after the "E" in the command. This will stop the command from failing, and so you should see that the website gets defaced.

    All of the other events just generate traffic for now.

    Feel free to look at how events are specified and experiment will making your own.

  • Message #34

    Hi! Finally I think I achieved mount the scenary properly. :-D I formatted the computer and install windows 10 Educational and it worked the first. When I had some time I will write down here all the steps that I did and my configurations.

    Have you any instructions on what to do in the scenario or the events that must occur?

    Thank you.

  • Message #33

    I don't think so. It is quite normal for there to be not found errors since the OccpAdmin program checks to see if something is already imported.

    You might also see the ACCESS_DENIED message, but then a later call to saveSettings that succeeds. In this case, everything is ok. In fact, since you got to apply phase 2, the import was successful.

    Are you running the vboxwebsrv on the same machine as the VirtualBox running the AdminVM? If not, make sure you specified the --remote flag to occpadmin as well. You'll need to have the SetupVPN installed on the host running vboxwebsrv for this to work.

  • Message #32

    I´m sure that my AdminVM has two network adapters:

    • the first one is a Bridge adaptar
    • the second one is an "Internal Network" called "OCCP_Setup" (NAT also doesn´t work)

    In both the adapter type is "Intel PRO/1000 MT Desktop (82540EM).

    I tried in promiscuous mode and not promiscuous mode.
    "eth1" is my network "OCCP_Setup" I also tried using "ifconfig eth1 up" and nothing...

    And I'm also sure I updated after rebuilding the machine, (I tried again and it returns it was already all updated)

    I realized that I have a previous error before (VER_ACCESS_DENIED), I attach here..:

    00:01:50.319317 SQW02    New SOAP thread started
    00:01:50.320294 SQW02    Processing connection from IP=192.168.1.52 socket=796 (
    0 out of 2 threads idle)
    00:01:50.426856 SQPmp    Request 3 on socket 744 queued for processing (1 items
    on Q)
    00:01:50.428810 SQW01    Processing connection from IP=192.168.1.52 socket=744 (
    0 out of 2 threads idle)
    00:01:50.666370 SQW01    API method name:            IMachine::FindSnapshot
    00:01:50.668326 SQW01    API return code:            0x80bb0001 (VBOX_E_OBJECT_N
    OT_FOUND)
    00:01:50.670281 SQPmp    Request 4 on socket 844 queued for processing (1 items
    on Q)
    00:01:50.672236 SQW03    New SOAP thread started
    00:01:50.675170 SQW01    COM error info result code: 0x80bb0001 (VBOX_E_OBJECT_N
    OT_FOUND)
    00:01:50.679080 SQW03    Processing connection from IP=192.168.1.52 socket=844 (
    0 out of 3 threads idle)
    00:01:50.682990 SQW01    COM error info text:        This machine does not have
    any snapshots
    00:01:50.786617 SQPmp    Request 5 on socket 860 queued for processing (1 items
    on Q)
    00:01:50.790527 SQW01    Processing connection from IP=192.168.1.52 socket=860 (
    0 out of 3 threads idle)
    00:02:20.419637 SQW02    API method name:            IMachine::SaveSettings
    00:02:20.422557 SQW02    API return code:            0x80004005 (E_FAIL)
    00:02:20.425490 SQW02    COM error info result code: 0x80004005 (E_FAIL)
    00:02:20.428423 SQW02    COM error info text:        Could not rename the direct
    ory 'C:\Users\FranciscodeBorja\VirtualBox VMs\gameserver' to 'C:\Users\Francisco
    deBorja\VirtualBox VMs\occp-rhinoribbons\gameserver' to save the settings file (
    VERR_ACCESS_DENIED)
    

    could that be the problem? Now I don't have any more ideas.

    Thanks!

  • Message #31

    No, you don't need to login to anything while the deployment is happening. The messages you are seeing are because the AdminVM can't contact the other VMs via SSH. Can you make sure that your AdminVM has it's second network adapter connected to an Internal Network called "OCCP_Setup"? Also watch to make sure rhinoblue and gameserver to get an IP address during boot (if they don't, it takes a couple of minutes to timeout, so you should see that happen instead).

    The code update was supposed to help with the VERR_ACCESS_DENIED issue. Did you apply the update after rebuilding the machine?

  • Message #30

    I downgraded the OS to Windows 8.1 and I don´t have that issue anymore. :-D

    Now when I execute the command: occpadmin --hvtype vbox --importdir C:
    OccpShared? --url http://192.168.1.38:18083/ --username --password --mode launch --config netdef.xml

    It adds three VMs to VirtualBox: router, rhinoblue (phase1) and gameserver (phase1); and starts rhinoblue (phase 1) and gameserver (phase1).

    It returns:

    INFO edu.uri.dfcsc.occp.OccpAdmin$1ImportVM call: Creating phase1 snapshot for the VM "gameserver" on the hypervisor "specified"
    INFO edu.uri.dfcsc.occp.OccpAdmin setupConfigManager: A Configuration Manager was setup was succesfully
    INFO edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "gameserver" on the hypervisor "specified"
    INFO edu.uri.dfcsc.occp.OccpAdmin$1ImportVM call: Creating phase1 snapshot for the VM "rhinoblue" on the hypervisor "specified"
    INFO edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "rhinoblue" on the hypervisor "specified"
    WARNING edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "gameserver" on the hypervisor "specified" has now failed 10 times. Retrying...
    WARNING edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "rhinoblue" on the hypervisor "specified" has now failed 10 times. Retrying...
    WARNING edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "gameserver" on the hypervisor "specified" has now failed 20 times. Retrying...
    WARNING edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "rhinoblue" on the hypervisor "specified" has now failed 20 times. Retrying...
    WARNING edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "gameserver" on the hypervisor "specified" has now failed 30 times. Retrying...
    WARNING edu.uri.dfcsc.occp.OccpAdmin$1PhaseFinish call: Applying phase 2 to the VM "rhinoblue" on the hypervisor "specified" has now failed 30 times. Retrying...
    

    I gues the problem is that I have to login in the gameserver, isn´t it?

    I didn´t find the password of "moderator" in netdef.xml, so I looked in another files and in "lastrun.pp" I found the next: moderator_password => '$6$1RD71SIp$kZ7hId3U5FG9I0nlq2S5TMlSjNI0qoqL8kk9DbRs.hwLIzBCBHlpRDjefI0IF4hsL8Iy6TVivljb/SyVJJqhh/', could this be the password?

    Thanks! EDIT: This is the error of VboxWebServices?: 00:01:45.174200 SQW02 API method name: IMachine::SaveSettings? 00:01:45.176155 SQW02 API return code: 0x80004005 (E_FAIL) 00:01:45.178110 SQW02 COM error info result code: 0x80004005 (E_FAIL) 00:01:45.179088 SQW02 COM error info text: Could not rename the direct ory 'C:\Users\FranciscodeBorja?\VirtualBox VMs\gameserver' to 'C:\Users\Francisco deBorja\VirtualBox VMs\occp-rhinoribbons\gameserver' to save the settings file ( VERR_ACCESS_DENIED)

    I´m trying to move it manually

  • Message #29

    Ok, so you do need to go back to 4.3. Unfortunately it seems like there is an issue with bridged networking and Windows 10 (see stack overflow). That links suggests that trying to run in Windows 8 compatibility mode might work, but it didn't work for everyone. Can you downgrade the OS?

  • Message #28

    Hi! 1. I already knew the issue with using VirtualBox 5 but I was trying with that newer version because with 4.3 didn´t work network bridge (only NAT)...do you have any idea to fix that? I tried with two different computers..and nothing.

    2. I also have some good neews, the -–importdir: "C:
    OccpShared?" works fine, but of course due to the version it creates the VMs in a wrong way.

    This is the result of each VM:

    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: Getting result of deploying Router
    SEVERE edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: HV: specified; VM Router; Code: CREATE_VM; Failed to create the VM
    Caused by: VirtualBox error: rc=0x8000ffff The session is not locked (session state: Unlocked) (0x8000ffff)
    edu.uri.dfcsc.occp.exceptions.vm.VMOperationFailedException: HV: specified; VM Router; Code: CREATE_VM; Failed to create the VM
    Caused by: VirtualBox error: rc=0x8000ffff The session is not locked (session state: Unlocked) (0x8000ffff)
            at edu.uri.dfcsc.occp.OccpVBoxHV.createVMwithISO(OccpVBoxHV.java:1416)
            at edu.uri.dfcsc.occp.OccpAdmin$1IsoVM.call(OccpAdmin.java:705)
            at edu.uri.dfcsc.occp.OccpAdmin$1IsoVM.call(OccpAdmin.java:682)
            at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
            at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            at java.lang.Thread.run(Thread.java:745)
    Caused by: org.virtualbox_4_3.VBoxException: VirtualBox error: rc=0x8000ffff The session is not locked (session state: Unlocked) (0x8000ffff)
            at org.virtualbox_4_3.ISession.getMachine(ISession.java:143)
            at edu.uri.dfcsc.occp.OccpVBoxHV.createVMwithISO(OccpVBoxHV.java:1398)
            ... 8 more
    Caused by: org.virtualbox_4_3.jaxws.RuntimeFaultMsg: VirtualBox error: rc=0x8000ffff The session is not locked (session state: Unlocked) (0x8000ffff) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) at sun.reflect.NativeConstructorAccessorImpl.newInstance (NativeConstructorAccessorImpl.java:57)at sun.reflect.DelegatingConstructorAccessorImpl.newInstance (DelegatingConstructorAccessorImpl.java:45)at java.lang.reflect.Constructor.newInstance(Constructor.java:526) at com.sun.xml.internal.ws.fault.SOAPFaultBuilder.createException(SOAPFaultBuilder.java:136) at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke (SyncMethodHandler.java:108) at com.sun.xml.internal.ws.client.sei.SyncMethodHandler.invoke (SyncMethodHandler.java:78)
            at com.sun.xml.internal.ws.client.sei.SEIStub.invoke(SEIStub.java:135)
            at com.sun.proxy.$Proxy24.iSessionGetMachine(Unknown Source)
            at org.virtualbox_4_3.ISession.getMachine(ISession.java:134)
            ... 9 more
    

    3. I ´ve already used that commands for updating the software (the instructions on Administrative VM under "Updates".)

  • Message #27

    The --importdir argument should be the path on the Host machine, such as "C:\OccpShared". This should also be the directory you have extracted the scenario into (i.e., it should be in C:\OccpShared\rhinoribbons").

    Also you will likely run into an issue using VirtualBox 5. The current code is designed to work with VirtualBox 4.3, and due to changes in the webservices API, it won't work against 5.

    You will also need to make sure you have updated the code inside the AdminVM, which may fix an issue with importing on a Windows host. See the instructions on Administrative VM under "Updates".

  • Message #26

    Ok...I´ve never used Vbox WebService? and I was using that in a wrong way.

    This is how you have to mount it with this environment: (just in case for someone who has no previous idea about that as me haha)

    VBoxWebSrv.exe -H 192.168.1.54 -A null
    

    And execute in AdminVM:

    occpadmin --hvtype vbox --importdir /mnt/OccpShared --url http://192.168.1.54:18083/ --username '' --password '' --mode launch --config netdef.xml
    

    Now I´m connected but it always fails with importing the "*.ova" from the shared folder.

    • I checked all the permissions, all directories and files have 777 permissions.
    • I can access to the shared folder through Windows and Ubuntu OS.
    • I mounted the shared folder with these commands:

    sudo Mkdir /mnt/OccpShared

    sudo mount -t vboxsf OccpShared? /mnt/OccpShared

    • The path "/mnt/OccpShared/rhinoribbons/gameserver.ova" is correct and the file *.ova exists.

    I don´t understand this line: INFO edu.uri.dfcsc.occp.SetupNetwork? stageFile: Copying /mnt/OccpShared/rhinoribbons/gameserver.ova to /mnt/OccpShared/rhinoribbons/gameserver.ova

    Is it trying to overwritte?

    Any ideas please?

    This is the return:

    INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Reading the scenario configuration file
    INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Finished reading the scenario configuration file
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Report directory: /mnt/OccpShared/rhinoribbons/Reports
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Moderator.txt
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Instructions.txt
    INFO edu.uri.dfcsc.occp.OccpAdmin main: Connected to specified
    INFO edu.uri.dfcsc.occp.OccpAdmin main: Checking appropriate networks exist on hypervisors
    INFO edu.uri.dfcsc.occp.SetupNetwork createConfiguration: Determined local IP for setup VPN to be: 192.168.1.56
    INFO edu.uri.dfcsc.occp.OccpAdmin main: Beginning setup of VMs
    INFO edu.uri.dfcsc.occp.OccpAdmin$1IsoVM call: Sending /home/occpadmin/occp/.occp/router.iso to the hypervisor "specified"
    INFO edu.uri.dfcsc.occp.SetupNetwork stageFile: Copying /home/occpadmin/occp/.occp/router.iso
    INFO edu.uri.dfcsc.occp.SetupNetwork stageFile: Copying /home/occpadmin/occp/.occp/router.iso to /mnt/OccpShared/rhinoribbons/router.iso
    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: Waiting for tasks to finish (2)
    INFO edu.uri.dfcsc.occp.OccpAdmin$1ImportVM call: Sending gameserver.ova to the hypervisor "specified"
    INFO edu.uri.dfcsc.occp.OccpAdmin$1IsoVM call: The hypervisor: "specified" received /home/occpadmin/occp/.occp/router.iso and will now create the VM "Router"
    INFO edu.uri.dfcsc.occp.SetupNetwork stageFile: Copying /mnt/OccpShared/rhinoribbons/gameserver.ova
    INFO edu.uri.dfcsc.occp.SetupNetwork stageFile: Copying /mnt/OccpShared/rhinoribbons/gameserver.ova to /mnt/OccpShared/rhinoribbons/gameserver.ova
    INFO edu.uri.dfcsc.occp.OccpAdmin$1ImportVM call: The hypervisor: "specified" received gameserver.ova and will now import it as the VM "gameserver"
    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: Getting result of deploying gameserver
    SEVERE edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: HV: specified; VM gameserver; Code: IMPORT; Failed to import the VM:Could not open the OVA file '/mnt/OccpShared/rhinoribbons/gameserver.ova' (VERR_PATH_NOT_FOUND)
    Data:
            virtualbox code=[-2135228412]
    edu.uri.dfcsc.occp.exceptions.vm.VMOperationFailedException: HV: specified; VM gameserver; Code: IMPORT; Failed to import the VM:Could not open the OVA file '/mnt/OccpShared/rhinoribbons/gameserver.ova' (VERR_PATH_NOT_FOUND)
    Data:
            virtualbox code=[-2135228412]
            at edu.uri.dfcsc.occp.OccpVBoxHV.importVM(OccpVBoxHV.java:678)
            at edu.uri.dfcsc.occp.OccpAdmin$1ImportVM.call(OccpAdmin.java:737)
            at edu.uri.dfcsc.occp.OccpAdmin$1ImportVM.call(OccpAdmin.java:711)
            at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
            at java.util.concurrent.FutureTask.run(FutureTask.java:262)
            at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
            at java.lang.Thread.run(Thread.java:745)
    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: Done with: gameserver
    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: VMs Complete:1/8, 1 Failed
    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: Failed: gameserver
    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: Waiting for tasks to finish (2)
    INFO edu.uri.dfcsc.occp.OccpAdmin$1ImportVM call: Sending rhinoblue.ova to the hypervisor "specified"
    

    {..............}

    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: Done with: gameserver, rhinoblue, rhinodb, rhinofileserver, rhinofw, Router, rhinomail, rhinowww
    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: VMs Complete:8/8, 8 Failed
    INFO edu.uri.dfcsc.occp.OccpAdmin checkVMsOnHV: Failed: gameserver, rhinoblue, rhinodb, rhinofileserver, rhinofw, Router, rhinomail, rhinowww
    SEVERE edu.uri.dfcsc.occp.OccpAdmin exitProgram: Please fix the above errors
    

    I´m very grateful of your attention bryank, thank you very much.

  • Message #25

    So it is a problem on the VirtualBox side. You should not see:

    00:00:00.011411 SQPmp    #### SOAP FAULT:  [SOAP-ENV:Server]
    

    But instead something like:

    Socket connection successful: host = 192.168.1.56, port = 18083, master socket = 8
    

    Please make sure that you have killed any existing vboxwebsrv processes you might have running.

    Also I am a little confused because you show the Ubuntu build string for VirtualBox, but you said you disabled the Windows Firewall. If you are running vboxwebsrv on an Ubuntu machine, did you check the firewall on that machine?

  • Message #24

    Hi bryank,

    I have dissabled all firewalls (of BitDefender? and Windows), and also I start vboxwebsrv NOT in background...but nothing :-(

    This message appears when I start vboxwebsrv:

    Oracle VM VirtualBox web service Version 4.3.10_Ubuntu
    (C) 2007-2015 Oracle Corporation
    All rights reserved.
    VirtualBox web service 4.3.10_Ubuntu r93012 linux.x86 (May 22 2015 02:58:51) release log
    00:00:00.000556 main     Log opened 2015-11-12T18:39:54.896280000Z
    00:00:00.000566 main     Build Type: release
    {...}
    00:00:00.000658 main     Package type: LINUX_32BITS_GENERIC (OSE)
    00:00:00.011411 SQPmp    #### SOAP FAULT:  [SOAP-ENV:Server]
    

    I´ll keep on it. Please if you have any idea or suggestion... I´m doing my final degree project about OCCP and If i weren´t able to make it work I would have to think in another one diferent, but that put me very sad because I love your idea and I´ve already spent so many hours.

  • Message #23

    My apologies. I saw that you were specifying a username and password which would be an issue, but I did not notice that you were getting "Connection refused". You might need to check that your host isn't blocking incoming connections via a firewall. Also, you might not want to start vboxwebsrv in the background, so you can make sure it is continuing to run and not failing after moving into the background.

  • Message #22

    Hi bryank, I´m sorry but I can not make it work despite of your help. And I´m not sure if I understood you at all.

    Please let me to revise all the steps...

    I have two networks on the VMadmin.

    configure webservice with this command:

    vboxwebsrv -b -H 192.168.1.56 -A null
    

    Located in the folder rhinoribbons...using username and passwod:

    occpadmin --hvtype vbox --importdir /mnt/OccpShared --url http://192.168.1.56:18083/ --username 'occpadmin' --pasword '0ccpadmin' --mode launch --config netdef.xml
    

    Obtain:

    INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Reading the scenario configuration file
    INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Finished reading the scenario configuration file
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Report directory: /mnt/OccpShared/rhinoribbons/Reports
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Moderator.txt
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Instructions.txt
    Please provide password for admin@http://192.168.1.56:18083/:
    SEVERE edu.uri.dfcsc.occp.OccpVBoxHV connect: Connection failure connecting to http://192.168.1.56:18083/
    org.virtualbox_4_3.VBoxException: HTTP transport error: java.net.ConnectException: Connection refused
    {......}
    

    Not using username and password:

     INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Reading the scenario configuration file
    INFO edu.uri.dfcsc.occp.OccpParser parseConfig: Finished reading the scenario configuration file
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Report directory: /mnt/OccpShared/rhinoribbons/Reports
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Moderator.txt
    INFO edu.uri.dfcsc.occp.OccpAdmin writeReports: Writing report: Instructions.txt
    Please provide password for null@http://192.168.1.56:18083/:
    SEVERE edu.uri.dfcsc.occp.OccpVBoxHV connect: Connection failure connecting to http://192.168.1.56:18083/
    org.virtualbox_4_3.VBoxException: HTTP transport error: java.net.ConnectException: Connection refused
    {...}
    

    What do you think i´m doing wrong?

    Thank you very much.

  • Message #21

    You should specify for the username and password, since the VirtualBox auth is set to null. If you want to use the VirtualBox host's credential system, you can run "VBoxManage setproperty websrvauthlibrary default" and then don't give "-A null" to the vboxwebsrv.

Tree View Flat View (newer first) Flat View (older first)

Attachments

No attachments created.

You must login to post a reply.